Configuración Router Cisco – NAT, DHCP, SSH y Consola

Topologia da rede

Siempre tenía que configurar el router de Cisco utilizando la misma configuración para todos, así que decidí crear este post para no olvidar más.

No voy a detallar lo que hace cada parámetro, sólo mostraré el escenario y la configuración lista. Al final tiene referencias para la consulta.

Nota: No se abordarán cuestiones de seguridad, buenas prácticas o optimización.

Ambiente

El escenario es un cliente que tiene un router de Cisco y que necesita:

  • El enrutador hace NAT
  • Sea DHCP Server
  • Acceder al router vía SSH
  • Solicitar contraseña al acceder al router a través del puerto de console

Topología de la red

rede
Topología de una red ficticia

 

Configuración

Router de borde

router-cliente#show running-config 
Building configuration...

Current configuration : 1208 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname router-cliente
!
!
!
!
ip dhcp excluded-address 192.168.1.1
!
ip dhcp pool DHCP-REDE-INTERNA
 network 192.168.1.0 255.255.255.0
 default-router 192.168.1.1
 dns-server 8.8.8.8
!
!
!
ip cef
no ipv6 cef
!
!
!
username admin privilege 15 secret 5 $1$mERr$1rh3F0pp5qjJWyvc3jEp31
!
!
license udi pid CISCO1941/K9 sn FTX1524DW90
!
!
!
!
!
!
!
!
!
ip ssh version 2
ip ssh time-out 90
ip domain-name avds.corp
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
 description WAN
 ip address 10.0.0.2 255.255.255.0
 ip nat outside
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 description LAN
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
ip nat inside source list 100 interface GigabitEthernet0/0 overload
ip classless
!
ip flow-export version 9
!
!
access-list 100 permit ip 192.168.1.0 0.0.0.255 any
!
!
!
!
!
line con 0
 password 1q2w3e4r5t
 login
!
line aux 0
!
line vty 0 4
 login local
 transport input ssh
line vty 5 15
 login local
 transport input ssh
!
!
!
end

provedor-internet#

Gateway

Current configuration : 675 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname provedor-internet
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO1941/K9 sn FTX1524799N
!
!
!
!
!
!
!
!
!
ip ssh version 2
ip domain-name operadora.corp
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
 ip address 10.0.0.1 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

provedor-internet#

 

 

Referencias

Organizando una base de datos de calles usando PHP y LibreOffice Calc

En una de mis tareas cotidianas, me encontré con este problema: ¿Cómo organizar una base de datos de calles? ¿Cómo podría hacerlo de manera práctica y utilizando herramientas ya disponibles?

Entonces resolvió utilizar PHP y LibreOffice Calc.

Contexto

Hay un S.I (ERP + CRM) donde se hace la gerencia de todos los clientes. En este sistema todas las informaciones del registro de persona física / jurídica se utilizan en otras partes del mismo sistema. El módulo de CRM de ese sistema utiliza, en una de sus funcionalidades, los datos de dirección (ciudad, barrio, calle) para posicionar al cliente en un mapa.

Hoy tengo acceso al base de datos del sistema pero no tengo permiso de escritura. Necesito corregir los problemas, enviar por ticket al soporte del sistema y un archivo CSV para que los cambios en el base de datos.

Problemas

Las calles registradas están fuera del estándar utilizado en el mapa donde se deben exhibir, con lo que es imposible ubicar al cliente en el mapa.

Esta es una lista de los elementos que serán corregidos:

  • Los logros que se refieren a la misma calle necesitan tener la misma grafía;
  • Abreviaturas en el nombre de la  Calles;
  • En la grafía de las calles que tiene números, necesitan estar por extenso;
  • Calles que tienen la numeración de inicio y fin en el nombre;
  • Calles con números romanos;

Solución desarrollada

En el primer momento, conversando con el equipo del Comercial, me dieron la idea de utilizar el LibreOffice Calc para organizar los datos y hacer las correcciones.

Obteniendo los datos, organizando y haciendo las primeras correcciones

Utilizando o LibreOffice Calc:

Obtuvo los datos accediendo a la base de datos PostgreSQL del sistema y ejecutando un SQL. He copiado los resultados para el LibreOffice Calc.

De ahí el nombre de las columnas facilitar la identificación y manipulación, quedó así:

ID LOGRADOURO CODBAIRRO CEP CODCIDADE

 

Dar nombre a las columnas me ayudó a la hora de usar la opción Clasificar de Calc. He seleccionado todo el área de la tabla donde estaba los datos, dentro de la opción CLASIFICAR, seleccioné la columna LOGRADOURO en la opción Clave de clasificación 1.

En el Calc, utilizando la opción Buscar y reemplazar he cambiado todos los registros que se encuadran en las condiciones:

TERMO SUBSTITUÍDO POR
R. Rua
R+ESPAÇO Rua
Tv. +ESPAÇO Travessa
RUA+ESPAÇO Rua
Av+ESPAÇO Avenida
Av.+ESPAÇO Avenida
Cel.+ESPAÇO Coronel
Dr.+ESPAÇO Doutor
Gen.+ESPAÇO General
Brig.+ESPAÇO Brigadeiro
Pre.+ESPAÇO Presidente

 

En algunos casos, existe discordancia si el logradouro es Calle, Avenida o Travessa. Esto tuvo que ser corregido también.

Utilizando PHP:

Después de hacer todas las correcciones manuales empecé a analizar los problemas para identificar cuáles serían posibles de ser resueltos usando programación en tiempo hábil.

El resultado del código desarrollado está abajo:

<?php
//ativando os erros
ini_set(‘display_errors’, ‘On’);
//Exibindo todos os erros
error_reporting(E_ALL);

$caminho_do_csv = '/var/www/html/lista-enderecos-mk.csv';
//O parâmetro FILE_TEXT especifica que o arquivo é retornado na codificação UTF-8.
$array_csv = file($caminho_do_csv, FILE_TEXT);
$map_csv = array_map('str_getcsv', $array_csv);

////////// PROBLEMAS PARA RESOLVER
//(Feito) 1- Encontrar um padrão e tudo que estiver a direita desse padrão deve ser apagado. Ex: numeração de inicio e fim no nome da rua.
//(Feito) 2- Retirar os numeros do nome do logradouro. Geralmente os numeros errados estão no final do nome.

//Função para exibir os dados de um mapa de array
// @return Sem terno
function exibe_mapa(Array $mapa_de_array)
{
if($mapa_de_array != NULL)
{
foreach ($mapa_de_array as $key => $valor)
{
print("Posição do Array exteno: ".$key."<br/>");
print("------ID: ".$valor[0]."<br/>");
print("------Logradouro: ".$valor[1]."<br/>");
print("------CODBAIRRO: ".$valor[2]."<br/>");
print("------CEP: ".$valor[3]."<br/>");
print("------CODCIDADE: ".$valor[4]."<br/>");
print('---------------------------------------------------------');
print("<br/>");
};
};
};

//Função para encontrar um padrão de texto em um mapa de array
// @return Sem terno
function encontrar_padrao(String $padrao, Array $mapa_de_array)
{
//percorrer o array para achar o padrão, se for encontrato, o texto é destacado:
//<font color='red'> texto </font>
$qtd_encontrada=0;
foreach ($mapa_de_array as $key => $valor) {
print("Posição do Array exteno: ".$key."<br/>");
print("------ID: ".$valor[0]."<br/>");
if(stripos($valor[1],$padrao) !== false){
print("------Logradouro: <font color='red'>".$valor[1]."</font><br/>");
$qtd_encontrada=$qtd_encontrada+1;
}else{
print("------Logradouro: ".$valor[1]."<br/>");
};
print('---------------------------------------------------------');
print("<br/>");
};
echo 'Total de ocorrências do padrão: '.$qtd_encontrada;
};

//Essa função contem o array com as strings que devem ser desconsideradas na busca por algum tipo de padrão de string.
// @return Retorna 1 se a string passado por parâmetro estever no array e 0 para caso contrário.
function padrao_desconsiderado(String $string)
{
//Array com os padrões que devem ser desconsiderados
$desconsiderar_padrao = array("ms-","MS-","Ms-","Rua ");
foreach($desconsiderar_padrao as $valor)
{
//A pergunta feita no IF é: Algum dos padrões que estão no array coincide com a string passada por parâmetro?
//Em outras palavras: $valor C $string || $valor esta CONTIDO em $string?
if(stripos($string,$valor) !== false){
return 1;
break;
};
};
return 0;
};

//Salvando em um arquivo CSV
// @return Sem terno
function salvando_no_arq_csv(Array $mapa_de_array)
{
//O primeiro parâmetro é o arquivo.csv que eu já criei e dei permissão 777 nele.
$fp = fopen('file.csv', 'w+');
foreach ($mapa_de_array as $key => $valor)
{
fputcsv($fp, $valor);
};

fclose($fp);
};

//Solução do problema 2
// @return Retorna o mapa de Array com os campos editados
function problema2(String $padrao, Array $mapa_de_array)
{
//percorrer o Array para achar o padrão.
//Depois eu edito a posição do array onde foi achado o padrão e salvo o novo texto editado;
$novo_mapa_de_array = $mapa_de_array;
foreach ($mapa_de_array as $key => $valor) {
if(stripos($valor[1],$padrao) !== false){
//posição onde foi encontrado o padrão
$posicao = stripos($valor[1],$padrao);
//Copiando o o valor(Array) que
$array_temp = $novo_mapa_de_array[$key];
$array_temp[1] = substr($array_temp[1],0,$posicao);
$novo_mapa_de_array[$key] = $array_temp;
};
};
return $novo_mapa_de_array;
};

//Função para encontrar um padrão que atende a expresão regular passada por parâmetro
// @return Retorna um mapa de Array com o texto corrigido
function problema3(String $expressao, Array $mapa_de_array)
{
//Variável que salva temporáriamente um mapa de array com os padrões encontrados;
$matches;
// Novo Array que será retornado contendo o texto editado
$novo_mapa_de_array = $mapa_de_array;

//percorrer o Array para achar o padrão, se for encontrato o padrão é excluido;
foreach ($mapa_de_array as $key => $valor)
{
//IMPORTANTE: a expressão precisa estár entre barras -> EX: /[0-9]/
if(preg_match('/'.$expressao.'/',$valor[1]))
{
if(padrao_desconsiderado($valor[1]) == 0){
preg_match('/'.$expressao.'/',$valor[1],$matches, PREG_OFFSET_CAPTURE);
$temp = $matches[0];
$array_temp = $novo_mapa_de_array[$key];
$array_temp[1] = substr($valor[1],0,$temp[1]);
$novo_mapa_de_array[$key] = $array_temp;
}else{
print_r("Valor: ".$valor[1]."<br/>");
printf("Variável temp[0] padrão: ".$temp[0]."<br/>");
printf("Variável temp[1] posição: ".$temp[1]."<br/><br/>");
}
}
};
return $novo_array_de_mapa;
};

//Resolve problema 2
//padrão para achar as ruas que tem a numeração de inicio e fim no nome
$padrao = ' - ';

//Resolve Problema 3
//Para achar numeros que estão no final do nome da rua
$expressao_problema_3 = '[0-9]{2,5}$';

$corrigido = problema2($padrao, $map_csv);

$corrigido2 = problema3($expressao_problema_3,$corrigido);

salvando_no_arq_csv($corrigido2);

?>

Resolviendo el problema de Packet Tracer 7.1.1 en Linux Mint 18 y 19

Yo estaba con mucha dificultad para hacer que el Packet Tracer funcione en mi Linux Mint. Después de buscar bastante y entrar en varios sitios, encontré una respuesta dada en Ask Ubuntu y en el Tech Otaku que me ayudaron a resolver el problema.

Voy a tomar este post para mostrar cómo resolví mis problemas con Packet Tracer en Linux Mint 18 e 19 (Sarah y Tara).

CONTEXTO

En Linux Mint 18 tuve problemas con esta versión de Packet Tracer. Cuando ejecuta el comando # packettracer aparecía un mensaje diciendo que el programa se estaba cargando, pero nunca abría. Para resolver este problema, basta con instalar el paquete que el profesor Samuel Henrique Bucke Brito indica en los comentarios de esa publicación.

En el Linux Mint 19 he hecho el mismo procedimiento descrito anteriormente y aún así no tuve éxito. Otros problemas surgieron, que sólo se resolvieron siguiendo otros tutoriales, principalmente la respuesta dada por Lucas Almeida a esa pregunta.

MI PROBLEMA

En el Mint 19 el Packet Tracer llega a abrir pero cuando intento expandir la ventana, el programa queda totalmente deforme.

AMBIENTE

S.O: Linux Mint 19 Cinnamon (Tara)
Kernel do Linux: 4.15.0-33-generic
Programa: Cisco Packet Tracer 7.1.1

SOLUCIONANDO EL PROBLEMA

EN EL LINUX MINT 18 (SARAH)

Después de instalar el Packet Tracer en la ruta predeterminada:

/opt/pt/

Tengo que editar el archivo:

/etc/apt/sources.list

agregando la línea:

deb http://security.ubuntu.com/ubuntu trusty-security main

Luego, ejecute los comandos:

sudo apt-get update
sudo apt-get install libicu52

o

wget http://mirrors.kernel.org/ubuntu/pool/main/i/icu/libicu52_52.1-3ubuntu0.8_amd64.deb
sudo dpkg -i libicu52_52.1-3ubuntu0.8_amd64.deb

Y por último reiniciar mi computadora.

EN EL LINUX MINT 19 (TARA)

Tengo que hacer el procedimiento anterior y también Instalar Qt libraries:

sudo apt-get install libqt5webkit5 libqt5multimediawidgets5 libqt5svg5 libqt5script5 libqt5scripttools5 libqt5sql5

Instalar libpng12:

wget http://ftp.debian.org/debian/pool/main/libp/libpng/libpng12-0_1.2.50-2+deb8u3_amd64.deb
sudo dpkg -i libpng12-0_1.2.50-2+deb8u3_amd64.deb

Y por último reiniciar mi computadora.

REFERENCIAS:

  • http://labcisco.blogspot.com/2017/08/lancamento-do-cisco-packet-tracer-71.html
  • https://vlanbr.wordpress.com/2017/09/19/resolvendo-problemas-na-instalacao-do-packet-tracer-7-1-no-debian-9/comment-page-1/#comment-20
  • https://www.tech-otaku.com/linux/getting-cisco-packet-tracer-71-to-run-on-ubuntu-1604-lts/
  • https://askubuntu.com/questions/1035523/packet-tracer-7-on-ubuntu-18-04-cannot-launch/1069009?newreg=c879977f82864bafb9db7de2b8da0b27