Configuración Router Cisco – NAT, DHCP, SSH y Consola

Topologia da rede

Siempre tenía que configurar el router de Cisco utilizando la misma configuración para todos, así que decidí crear este post para no olvidar más.

No voy a detallar lo que hace cada parámetro, sólo mostraré el escenario y la configuración lista. Al final tiene referencias para la consulta.

Nota: No se abordarán cuestiones de seguridad, buenas prácticas o optimización.

Ambiente

El escenario es un cliente que tiene un router de Cisco y que necesita:

  • El enrutador hace NAT
  • Sea DHCP Server
  • Acceder al router vía SSH
  • Solicitar contraseña al acceder al router a través del puerto de console

Topología de la red

rede
Topología de una red ficticia

 

Configuración

Router de borde

router-cliente#show running-config 
Building configuration...

Current configuration : 1208 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname router-cliente
!
!
!
!
ip dhcp excluded-address 192.168.1.1
!
ip dhcp pool DHCP-REDE-INTERNA
 network 192.168.1.0 255.255.255.0
 default-router 192.168.1.1
 dns-server 8.8.8.8
!
!
!
ip cef
no ipv6 cef
!
!
!
username admin privilege 15 secret 5 $1$mERr$1rh3F0pp5qjJWyvc3jEp31
!
!
license udi pid CISCO1941/K9 sn FTX1524DW90
!
!
!
!
!
!
!
!
!
ip ssh version 2
ip ssh time-out 90
ip domain-name avds.corp
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
 description WAN
 ip address 10.0.0.2 255.255.255.0
 ip nat outside
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 description LAN
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
ip nat inside source list 100 interface GigabitEthernet0/0 overload
ip classless
!
ip flow-export version 9
!
!
access-list 100 permit ip 192.168.1.0 0.0.0.255 any
!
!
!
!
!
line con 0
 password 1q2w3e4r5t
 login
!
line aux 0
!
line vty 0 4
 login local
 transport input ssh
line vty 5 15
 login local
 transport input ssh
!
!
!
end

provedor-internet#

Gateway

Current configuration : 675 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname provedor-internet
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO1941/K9 sn FTX1524799N
!
!
!
!
!
!
!
!
!
ip ssh version 2
ip domain-name operadora.corp
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
 ip address 10.0.0.1 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

provedor-internet#

 

 

Referencias

Resolviendo el problema de Packet Tracer 7.1.1 en Linux Mint 18 y 19

Yo estaba con mucha dificultad para hacer que el Packet Tracer funcione en mi Linux Mint. Después de buscar bastante y entrar en varios sitios, encontré una respuesta dada en Ask Ubuntu y en el Tech Otaku que me ayudaron a resolver el problema.

Voy a tomar este post para mostrar cómo resolví mis problemas con Packet Tracer en Linux Mint 18 e 19 (Sarah y Tara).

CONTEXTO

En Linux Mint 18 tuve problemas con esta versión de Packet Tracer. Cuando ejecuta el comando # packettracer aparecía un mensaje diciendo que el programa se estaba cargando, pero nunca abría. Para resolver este problema, basta con instalar el paquete que el profesor Samuel Henrique Bucke Brito indica en los comentarios de esa publicación.

En el Linux Mint 19 he hecho el mismo procedimiento descrito anteriormente y aún así no tuve éxito. Otros problemas surgieron, que sólo se resolvieron siguiendo otros tutoriales, principalmente la respuesta dada por Lucas Almeida a esa pregunta.

MI PROBLEMA

En el Mint 19 el Packet Tracer llega a abrir pero cuando intento expandir la ventana, el programa queda totalmente deforme.

AMBIENTE

S.O: Linux Mint 19 Cinnamon (Tara)
Kernel do Linux: 4.15.0-33-generic
Programa: Cisco Packet Tracer 7.1.1

SOLUCIONANDO EL PROBLEMA

EN EL LINUX MINT 18 (SARAH)

Después de instalar el Packet Tracer en la ruta predeterminada:

/opt/pt/

Tengo que editar el archivo:

/etc/apt/sources.list

agregando la línea:

deb http://security.ubuntu.com/ubuntu trusty-security main

Luego, ejecute los comandos:

sudo apt-get update
sudo apt-get install libicu52

o

wget http://mirrors.kernel.org/ubuntu/pool/main/i/icu/libicu52_52.1-3ubuntu0.8_amd64.deb
sudo dpkg -i libicu52_52.1-3ubuntu0.8_amd64.deb

Y por último reiniciar mi computadora.

EN EL LINUX MINT 19 (TARA)

Tengo que hacer el procedimiento anterior y también Instalar Qt libraries:

sudo apt-get install libqt5webkit5 libqt5multimediawidgets5 libqt5svg5 libqt5script5 libqt5scripttools5 libqt5sql5

Instalar libpng12:

wget http://ftp.debian.org/debian/pool/main/libp/libpng/libpng12-0_1.2.50-2+deb8u3_amd64.deb
sudo dpkg -i libpng12-0_1.2.50-2+deb8u3_amd64.deb

Y por último reiniciar mi computadora.

REFERENCIAS:

  • http://labcisco.blogspot.com/2017/08/lancamento-do-cisco-packet-tracer-71.html
  • https://vlanbr.wordpress.com/2017/09/19/resolvendo-problemas-na-instalacao-do-packet-tracer-7-1-no-debian-9/comment-page-1/#comment-20
  • https://www.tech-otaku.com/linux/getting-cisco-packet-tracer-71-to-run-on-ubuntu-1604-lts/
  • https://askubuntu.com/questions/1035523/packet-tracer-7-on-ubuntu-18-04-cannot-launch/1069009?newreg=c879977f82864bafb9db7de2b8da0b27