Criando alias no Linux

Alias são “apelidos” que podemos dar a um comando, que geralmente é grande e queremos evitar de digitar toda vez. No meu caso é cd /var/www/html.

Para saber quais alias estão ativos, use o comando: 

alias

Para criar um alias novo:

alias <apelido>=”<comando a ser executado>”

Exemplo usando o meu caso:

alias @=”cd /var/www/html”  OU  alias www=”cd /var/www/html”

Ao digitar @ ou www, e pressionar Enter no terminal, o comando cd /var/www/html será executado.

Para excluir um aliás:

unalias <nome do alias>

Exemplo: 

unalias www

Para deixar persistente o alias no seu usuário do S.O, crie o arquivo /home/seu-user/.bash_aliases e insira no arquivo os alias criados.

Exemplo de arquivo .bash_aliases:

alias @="cd /var/www/html"
alias ..="cd ../"

Referências: 

Configuração de resolução em um segundo monitor

Cenário de aplicação do exemplo

Um notebook com Linux Mint 19, usando um segundo monitor Samsung SyncMaster 933.

Problema

Ao conectar um segundo monitor ao notebook,  a resolução máxima suportada é 1024×768 60.00Hz.

Solução

1- execute o comando xrandr e procure pelo monitor auxiliar. A saída será parecida com essa:

VGA-1 connected 1368x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768      60.00  
   800x600       60.32    56.25  
   848x480       60.00  

No meu caso o monitor é o VGA-1.

2- Criando um novo perfil para o segundo monitor:

xrandr --newmode "1366x768_60.00"   85.25  1368 1440 1576 1784  768 771 781 798 -hsync +vsync

Eu sei que o meu monitor suporta a resolução de 1366×768 a 60Hz, se você não souber o seu leia esse post na parte que fala de cvt.

3- Atribuindo o novo perfil:

xrandr --addmode VGA-1 1366x768_60.00

4- Ativando

xrandr --output VGA-1 --mode 1366x768_60.00

Nesse ponto você também pode ativar pela interface gráfica do S.O. Se o monitor em questão for um que você frequentemente usa, toda vez que ligar o PC terá que executar os comandos acima. Para automatizar esse processo você pode no final do arquivo /home/SEU-USER/.profile adicionar o scritp abaixo:

###### CONFIGURAÇÃO DE MONITOR AUXILIAR ######

# Se você usa notebook com um segundo monitor, a verificação abaixo junto com o IF do final é necessário para evitar um  erro caso o notebook seja ligado sem o monitor estar conectado.

##verifico se o monitor está conectado
monitor=$(xrandr | grep -o 'VGA-1 connected')

#crio o perfil do monitor
xrandr --newmode "1366x768_60.00"   85.25  1368 1440 1576 1784  768 771 781 798 -hsync +vsync
xrandr --addmode VGA-1 1366x768_60.00

# condição para ativar o perfil, caso o monitor esteja conectado
if [ "$monitor" ]; then
    xrandr --output VGA-1 --mode 1366x768_60.00
fi

Leia o script e substitua as ocorrências ‘VGA-1’ pelo identificador do seu monitor.

Referências:

Como conectar em uma rede wireless pela linha de comando no linux

A ferramenta para conectar varia conforme o tipo de criptografia utilizada no processo de autenticação:

Para somente o tipo WEP use o iw
Para os tipos WEP, WPA and WPA2 use o wpasupplicant

Instalação e configuração utilizando iw

No Ubuntu Server esse aplicativo já vem instalado, basta chamar na CLI por:

iw

Instalação da ferramenta

apt-get install iw 

Exibir placa de rede wireless do computador

iwconfig

Listar as redes wifi captadas pela placa wireless

iwlist scan
ou
iwlist <sua interface wireless> scan

Conectar da rede wi-fi

iwconfig wlan0 essid <NOME-DA-REDE> mode managed

Caso precise obter IP utilize o DHCLIENT

dhclient -v <sua-interface-wi-fi>

Instalação e configuração utilizando wpasupplicant

Instalação da ferramenta

apt-get install wpasupplicant

Arquivo de configuração. Se ele não estiver criado, você deve criar

/etc/wpa_supplicant.conf

Configuração:

network={
    ssid="ssid_name"
    psk="password"
}

Assumindo que a sua interface é wlan0:

wpa_supplicant -B -i wlan0 -c /etc/wpa_supplicant.conf -D wext

Caso precise obter IP utilize o DHCLIENT

dhclient -v <sua-interface-wi-fi>

Fontes

  1. https://sempreupdate.com.br/como-conectar-wifi-via-terminal-linux/
  2. https://askubuntu.com/questions/138472/how-do-i-connect-to-a-wpa-wifi-network-using-the-command-line

Como instalar o Postgre e pgAdmin no Linux (Ubuntu e derivados)

Passo a passo não muito detalhado da instalação do SGBD PostgreSQL 9.5 e a ferramenta gráfica da administração pgAdmin 4. Para mais informações leia a documentação do Postgresql e pgAdmin.

Adicionando o repositório do PostGreSQL para a versão Bionic (18.04) do Ubuntu:

– Crie o arquivo /etc/apt/sources.list.d/pgdg.list e adi cione a linha abaixo:

deb http://apt.postgresql.org/pub/repos/apt/ bionic-pgdg main

– Importe a chave de assinatura do repositório e atualize as listas de pacotes

wget --quiet -O - https://www.postgresql.org/media/keys/ACCC4CF8.asc | sudo apt-key add -
sudo apt-get update

Instalando o PostgreSQL 12

– Execute a linha abaixo

sudo apt-get install postgresql-12

Instalando o pgAdmin 4

– Execute a linha abaixo

sudo apt-get install pgadmin4

Criando o banco de dados pelo terminal

Primeiro precisamos acessar o prompt de comando do usuário postgres. Este usuário foi criado automaticamente na instalação do PostgresSQL.

sudo su - postgres

– Para criar o banco de dados:

createdb bancoTeste

– Entrando no cliente de linha de comando do PostgreSQL e manipulando o BD criado:

psql -d bancoTeste

Nesse estágio você pode manipular o banco utilizando a linguagem SQL do Postgres.

– Atribuindo uma senha o usuário postgres.

É importante destacar que esse senha é para o usuário postgres do PostgresSQL, não é a senha para o BD bancoTeste.

Ainda dentro do client de linha de comando do Postgre digite:

\password postgres

Ele vai pedir que você digite a nova senha duas vezes.

Para mais informações digite:

help

Acessando o pgAdmin 4

– Você pode pesquisar no menu de aplicativos do seu S.O por: pgadmin4

– Ou iniciando pelo terminal usando o comando: pgadmin4

– A partir do usuário postgres você consegue criar e logar nos bancos.

O servidor será iniciado e a partir daí é com você.

Referências

Configuração Router Cisco – NAT, DHCP, SSH e Console

Topologia da rede

Eu sempre tinha que configurar roteador Cisco usando a mesma configuração para todos, então resolvi criar esse post para não esquecer mais.

Eu não vou detalhar o que cada parâmetro faz, só mostrarei o cenário e a configuração pronta. No final tem referências para consulta.

Observação: Não será abordado questões de segurança, boas práticas ou otimização.

Cenário

O cenário é um cliente que tem um router Cisco e precisa que:

  • O router faça NAT
  • Seja o DHCP Server
  • Acessar o router via SSH
  • Solicitar senha ao acessar o router via porta console

 

Topologia da rede

Topologia da rede
Topologia da uma rede hipotética

 

Configuração

Router de borda

router-cliente#show running-config 
Building configuration...

Current configuration : 1208 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname router-cliente
!
!
!
!
ip dhcp excluded-address 192.168.1.1
!
ip dhcp pool DHCP-REDE-INTERNA
 network 192.168.1.0 255.255.255.0
 default-router 192.168.1.1
 dns-server 8.8.8.8
!
!
!
ip cef
no ipv6 cef
!
!
!
username admin privilege 15 secret 5 $1$mERr$1rh3F0pp5qjJWyvc3jEp31
!
!
license udi pid CISCO1941/K9 sn FTX1524DW90
!
!
!
!
!
!
!
!
!
ip ssh version 2
ip ssh time-out 90
ip domain-name avds.corp
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
 description WAN
 ip address 10.0.0.2 255.255.255.0
 ip nat outside
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 description LAN
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
ip nat inside source list 100 interface GigabitEthernet0/0 overload
ip classless
!
ip flow-export version 9
!
!
access-list 100 permit ip 192.168.1.0 0.0.0.255 any
!
!
!
!
!
line con 0
 password 1q2w3e4r5t
 login
!
line aux 0
!
line vty 0 4
 login local
 transport input ssh
line vty 5 15
 login local
 transport input ssh
!
!
!
end

router-cliente#

Router Gateway

provedor-internet#show running-config 
Building configuration...

Current configuration : 675 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname provedor-internet
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO1941/K9 sn FTX1524799N
!
!
!
!
!
!
!
!
!
ip ssh version 2
ip domain-name operadora.corp
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
 ip address 10.0.0.1 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

provedor-internet#

Referências