Taxonomia de links salvos no Favoritos do navegador

Tema

Esse texto explica o método que desenvolvi para organizar os links de páginas na internet que salvo nos Favoritos do navegador.

Contexto

A medida que pesquiso sobre várias áreas do conhecimento, encontro conteúdos bons e que valem apena serem salvos. Nesse processo de salvar os links nos Favoritos do navegador, sempre tive dificuldade em organizá los de tal forma a facilitar o encontro e sem deixar de lado a categorização correta.

A taxonomia de links

Para estruturar o conceito desenvolvido elaborei leis que devem ser obedecidas e objetivos que devem ser atendidos.

As leis

  1. O sistema taxonômico deve ser baseado nas principais áreas correntes*.
  2. Grandes subdivisões, subcategorias ou ramificações não são recomendadas.
  3. Se um link a ser salvo poder pertencer a mais de uma categoria, ele deve ser salvo onde na área corrente onde faz mais sentido no uso do no dia-a-dia.
  4. Os termos utilizados na nomenclatura devem pertencer ao domínio de conhecimento do usuário.
  5. Só deve ser criado uma pasta para links que pertencem a uma mesma categoria, se ouvir links de diferentes categorias, eles devem ficar fora de pasta, todos juntos.
  6. O link devem ser categorizados a partir do que ele trata, e não o que foi feito com ele.

Os objetivos

Esse objetivos são alvos que tentamos alcançar na elaboração deste sistema taxonômico, mas pode acontecer não conseguirmos atingir todos eles.

  1. Facilitar a localização e armazenamento dos links.
  2. A organização deve ser clara;

 

 

Exemplo de aplicação

1- Separando as áreas correntes:

  • Faculdade
  • Trabalho
  • Particular

2- Acrescentando suas possíveis categorias

  • Faculdade
    • TCC
      • Ferramentas
    • Matérias

 

  • Trabalho
    • Ferramentas internas

 

  • Pessoal
    • Redes
      • DNS
      • SNMP
      • CISCO
    • Linux
      • SystemCTL
      • PacketTracer
      • Shell Script
    • Programação
      • Banco de Dados
      • Frontend
    • Baixar/Comprar livros
    • Fonte de conhecimento
    • Ler depois
      • Curiosidades
    • Financeiro
    • Cursos e materiais de estudo
      • Redes
      • Linux
      • Programação
      • Energia fotovoltaica
    • Arduino

3- Validar se as leis foram cumpridas.

 

4- Executar o plano

 

Glossário

A

Área corrente –  Neste contexto entende se por uma área do conhecimento ou vida do ator principal que está mais destaca no dia-a-dia. É importante entender que a área corrente pode mudar conforme muda a vida do ator.

 

Referências

Como instalar o Postgre e pgAdmin no Linux (Ubuntu e derivados)

Passo a passo não muito detalhado da instalação do SGBD PostgreSQL 9.5 e a ferramenta gráfica da administração pgAdmin 4. Para mais informações leia a documentação do Postgresql e pgAdmin.

Adicionando o repositório do PostGreSQL para a versão Bionic (18.04) do Ubuntu:

– Crie o arquivo /etc/apt/sources.list.d/pgdg.list e adi cione a linha abaixo:

deb http://apt.postgresql.org/pub/repos/apt/ bionic-pgdg main

– Importe a chave de assinatura do repositório e atualize as listas de pacotes

wget --quiet -O - https://www.postgresql.org/media/keys/ACCC4CF8.asc | sudo apt-key add -
sudo apt-get update

Instalando o PostgreSQL 12

– Execute a linha abaixo

sudo apt-get install postgresql-12

Instalando o pgAdmin 4

– Execute a linha abaixo

sudo apt-get install pgadmin4

Criando o banco de dados pelo terminal

Primeiro precisamos acessar o prompt de comando do usuário postgres. Este usuário foi criado automaticamente na instalação do PostgresSQL.

sudo su - postgres

– Para criar o banco de dados:

createdb bancoTeste

– Entrando no cliente de linha de comando do PostgreSQL e manipulando o BD criado:

psql -d bancoTeste

Nesse estágio você pode manipular o banco utilizando a linguagem SQL do Postgres.

– Atribuindo uma senha o usuário postgres.

É importante destacar que esse senha é para o usuário postgres do PostgresSQL, não é a senha para o BD bancoTeste.

Ainda dentro do client de linha de comando do Postgre digite:

\password postgres

Ele vai pedir que você digite a nova senha duas vezes.

Para mais informações digite:

help

Acessando o pgAdmin 4

– Você pode pesquisar no menu de aplicativos do seu S.O por: pgadmin4

– Ou iniciando pelo terminal usando o comando: pgadmin4

– A partir do usuário postgres você consegue criar e logar nos bancos.

O servidor será iniciado e a partir daí é com você.

Referências

Configuração Router Cisco – NAT, DHCP, SSH e Console

Topologia da rede

Eu sempre tinha que configurar roteador Cisco usando a mesma configuração para todos, então resolvi criar esse post para não esquecer mais.

Eu não vou detalhar o que cada parâmetro faz, só mostrarei o cenário e a configuração pronta. No final tem referências para consulta.

Observação: Não será abordado questões de segurança, boas práticas ou otimização.

Cenário

O cenário é um cliente que tem um router Cisco e precisa que:

  • O router faça NAT
  • Seja o DHCP Server
  • Acessar o router via SSH
  • Solicitar senha ao acessar o router via porta console

 

Topologia da rede

Topologia da rede
Topologia da uma rede hipotética

 

Configuração

Router de borda

router-cliente#show running-config 
Building configuration...

Current configuration : 1208 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname router-cliente
!
!
!
!
ip dhcp excluded-address 192.168.1.1
!
ip dhcp pool DHCP-REDE-INTERNA
 network 192.168.1.0 255.255.255.0
 default-router 192.168.1.1
 dns-server 8.8.8.8
!
!
!
ip cef
no ipv6 cef
!
!
!
username admin privilege 15 secret 5 $1$mERr$1rh3F0pp5qjJWyvc3jEp31
!
!
license udi pid CISCO1941/K9 sn FTX1524DW90
!
!
!
!
!
!
!
!
!
ip ssh version 2
ip ssh time-out 90
ip domain-name avds.corp
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
 description WAN
 ip address 10.0.0.2 255.255.255.0
 ip nat outside
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 description LAN
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
ip nat inside source list 100 interface GigabitEthernet0/0 overload
ip classless
!
ip flow-export version 9
!
!
access-list 100 permit ip 192.168.1.0 0.0.0.255 any
!
!
!
!
!
line con 0
 password 1q2w3e4r5t
 login
!
line aux 0
!
line vty 0 4
 login local
 transport input ssh
line vty 5 15
 login local
 transport input ssh
!
!
!
end

router-cliente#

Router Gateway

provedor-internet#show running-config 
Building configuration...

Current configuration : 675 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname provedor-internet
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO1941/K9 sn FTX1524799N
!
!
!
!
!
!
!
!
!
ip ssh version 2
ip domain-name operadora.corp
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
 ip address 10.0.0.1 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

provedor-internet#

Referências

Águas do Espírito

Como águas profundas que brotam, sou gerado do chão.

E na busca de um caminho, por rios perigosos fui atraído.

Misturado num percurso de ilusão, fui jogado em inevitáveis

quedas sobre as rochas da realidade.

Afogando oportunidades,  sonhos,  esperanças e fé.

Levadas por turbilhões e tempestades que passaram dentro do meu coração.

 

Por longos desertos áridos fui iludido.

Impiedosamente sugado pelas ciladas do mundo.

O intenso brilho da verdade foi contaminado pelas águas escuras da mentira.

Mas de repente, agonizando dentro de um buraco, escondido em um profundo abismo, supliquei por socorro.

 

Então fui inundado por tempestades colossais.

O Espírito Santo sufocou meus pecados, me encheu de vida por meio do amor de Deus que entra pelas rachaduras das feridas que ardem no fundo do meu coração cansado.

Me ressuscitou com o azeite da sabedoria, me impulsionou a transbordar sobre as pedras ressecadas em meu caminho.

 

Afogou com luz as turvas águas das minhas vontades.

Iluminou a senda do meu pensamento.

Me encorajou a lançar-me na rebentação da fé, sendo definitivamente parte do infinito oceano, que toca terras distantes com águas oferecidas por Deus.

 

Autor:  um amigo ex-dependente químico.

Resolvendo problema do Packet Tracer 7.1.1 no Linux Mint 18 e 19

Eu estava com muita dificuldade para fazer o Packet Tracer funcionar no meu Linux Mint. Depois de pesquisar bastante e rodar por vários sites, achei uma resposta dada no Ask Ubuntu e no Tech Otaku que me ajudaram a resolver o problema.

Vou aproveitar esse post para mostrar como resolvi meus problemas com o Packet Tracer no Linux Mint 18 e 19 (Sarah e Tara).

CONTEXTO

No Linux Mint 18 eu tinha problema com essa versão do Packet Tracer. Quando executava o comando # packettracer aparecia uma mensagem dizendo que o programa estava sendo carregado, mas nunca abria. Para resolver esse problema, bastava instalar o pacote que professor Samuel Henrique Bucke Brito indica nos comentários dessa publicação.

Já no Linux Mint 19 eu fiz o mesmo procedimento descrito anteriormente e mesmo assim não tive sucesso. Outros problemas surgiram, que só foram resolvidos seguindo outros tutoriais, principalmente a resposta dada pelo Lucas Almeida a essa pergunta.

MEU PROBLEMA

No Mint 19 o Packet Tracer chega abrir mas quando tento expandir a janela, o programa fica totalmente disforme.

AMBIENTE

S.O: Linux Mint 19 Cinnamon (Tara)

Kernel do Linux: 4.15.0-33-generic

Programa: Cisco Packet Tracer 7.1.1

RESOLVENDO O PROBLEMA

NO LINUX MINT 18 (SARAH)

Depois de instalar o Packet Tracer no caminho padrão:

/opt/pt/

tenho que editar o arquivo:

/etc/apt/sources.list

adicionando a linha:

deb http://security.ubuntu.com/ubuntu trusty-security main

Logo depois executar os comandos:

sudo apt-get update
sudo apt-get install libicu52

ou

wget http://mirrors.kernel.org/ubuntu/pool/main/i/icu/libicu52_52.1-3ubuntu0.8_amd64.deb
sudo dpkg -i libicu52_52.1-3ubuntu0.8_amd64.deb

E por último reiniciar meu computador.

NO LINUX MINT 19(TARA)

Tenho que fazer o procedimento acima e também Instalar o Qt libraries:

sudo apt-get install libqt5webkit5 libqt5multimediawidgets5 libqt5svg5 libqt5script5 libqt5scripttools5 libqt5sql5

Instalar o libpng12:

wget http://ftp.debian.org/debian/pool/main/libp/libpng/libpng12-0_1.2.50-2+deb8u3_amd64.deb
sudo dpkg -i libpng12-0_1.2.50-2+deb8u3_amd64.deb

E por último reiniciar meu computador.

REFERÊNCIAS: